Browsed by
标签: deepin-wine

下列软件包有未满足的依赖关系: libgirepository-1.0-1 : 破坏: python-gi (< 3.42.0-1+b1) 但是 3.30.4-1 正要被安装

下列软件包有未满足的依赖关系: libgirepository-1.0-1 : 破坏: python-gi (< 3.42.0-1+b1) 但是 3.30.4-1 正要被安装

Debian 11 bullseye testing 在 使用 sudo apt dist-upgrade 更新后,出现如下错误:

下列软件包有未满足的依赖关系:
libgirepository-1.0-1 : 破坏: python-gi (< 3.42.0-1+b1) 但是 3.30.4-1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

并且 deepin-wine QQ、TIM、Photoshop CS 6 均无法使用。

看了网上很多解决 libgirepository-1.0-1 的文章,都无法解决,再经历了几次备份、还原后,总结出来的方法。

卸载依赖出错的源头 libgirepository-1.0-1(当前为系统最新版)

手动安装 libgirepository-1.0-1_1.64.0-2_amd64.debgir1.2-glib-2.0_1.64.0-2_amd64.debpython-gi_3.36.0-1_amd64.deb(deepin-wine所需旧版本)

此方法仅为临时解决方案,正常使用 sudo apt update、sudo apt upgrade 更新、升级,无异常。如果使用 sudo apt dist-upgrade 更新、升级,则重复之前的错误,需按此方法重新解决。